Вопрос по информатике:
Задание: написать программу, вычисляющую произведение элементов одномерного массива Z(N).
Рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение P:=P*Z[k] перед циклическим процессом нужно задать как 1, т.е. P:=1;
Ввод и вывод массива выполните через текстовый файл.
- 04.11.2017 14:37
- Информатика
- remove_red_eye 4417
- thumb_up 27
Ответы и объяснения 1
Var Z:array[1..100] as integer; P:integer; i,n:integer; begin Reset(input,'input.txt'); Rewrite(output,'output.tx); readln(n); For i:=1 to n do Readln(Z[i]); P:=1; For i:=1 to n do P:=p*z[i]; Writeln(p); Close(input); Close(output); end.
- 05.11.2017 14:56
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.