Вопрос по информатике:
Напишите программу, которая случайным образом выбирает дежурных: выводит два случайных числа в диапазоне от 1 до N, где N- количество учеников вашего класса. С какой проблемой вы можете столкнуться?
Нужно сделать в Паскале. Заранее спасибо!
- 13.07.2018 18:19
- Информатика
- remove_red_eye 14654
- thumb_up 7
Ответы и объяснения 2
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
var
n,n1,n2:integer;
begin
Write('Количество учеников: '); Read(n);
Randomize;
n1:=Random(n)+1;
n2:=n1;
while n2=n1 do n2:=Random(n)+1;
Writeln('Номера дежурных: ',n1,', ',n2)
end.
Тестовое решение:
Количество учеников: 35
Номера дежурных: 2, 26
- 14.07.2018 12:27
- thumb_up 38
Var n,d1,d2:integer;
begin
writeln('Укажите сколько человек в классе:');
readln(n);
Randomize;
d1:=Random(1,n);
d2:=Random(1,n);
while d1=d2 do d2:=Random(1,n);
writeln('Дежурными назначены: ',d1,' и ',d2);
end.
цикл while d1=d2 do d2:=Random(1,n); сделан, чтобы исключить возможность совпадения номеров (когда генератор случайных чисел одинаковые номера выдаст)
- 15.07.2018 09:25
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.