Вопрос по информатике:
Написать программу: Дано 5 произвольных натуральных чисел. Найти среднее арифметическое отрицательных кратных пяти.
- 24.03.2016 00:12
- Информатика
- remove_red_eye 7254
- thumb_up 16
Ответы и объяснения 1
Program z1;
var
mas: array[1..10] of integer;
i,s,sr,k: integer;
begin
s:=0;
k:=0;
writeln('Введите 5 чисел');
for i:=1 to 5 do
begin
readln(mas[i]);
if (mas[i]<0) and (mas[i] mod 5=0) then
begin
s:=s+mas[i];
k:=k+1;
end;
end;
sr:=s div k;
writeln('Среднее арифметическое чисел, кратных 5, равно ',sr);
end.
- 25.03.2016 11:31
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.