Вопрос по информатике:
Написать программу, в которой массив из 20 элементов заполняется случайными числами и вычисляется произведение всех элементов массива.
- 09.01.2018 22:49
- Информатика
- remove_red_eye 8217
- thumb_up 31
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
var a:=ArrRandom(20,-15,25); a.Println;
var p:BigInteger:=1;
foreach var x in a do p*=x;
Writeln('Произведение элементов равно ',p)
end.
Тестовое решение:
-3 5 8 -14 10 19 18 -15 15 -13 22 9 7 20 -12 6 6 -8 -3 -8
Произведение элементов равно 38640208365158400000
- 01.01.1970 00:00
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.