Вопрос по информатике:
Составить программу для подсчета количества "счастливых" шестизначных билетов, при исполнении которой работает не более 50000 арифметических команд.
В чем ошибка?
program upr4;
var n,m,i:longint;
a,b,c,e,f,k: integer;
begin
m:=0;
for i:= 100000 to 999999 do begin
k:= n mod 10;
f:= (n div 10) mod 10;
e:= (n div 100) mod 10;
c:= (n div 1000) mod 10;
b:= (n div 10000) mod 10;
a:= (n div 100000) mod 10;
if k+f+e=a+b+c
then m:=m+1
else m:=m;end;
writeln (m);
end.
- 13.05.2017 04:41
- Информатика
- remove_red_eye 4661
- thumb_up 22
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.