Вопрос по информатике:
Написать программу на языке си++ вычислить сумму ряда до 20 члена s=((-1)*(k!+1)*x^k)/3^k
- 13.04.2017 18:02
- Информатика
- remove_red_eye 7563
- thumb_up 30
Ответы и объяснения 1
Исходя из вашего запроса:
без отрицания k
#include
using namespace std;
int main()
{
int a,k,s,x;
for (k=0; k<20; k++)
{
s +=((-1)*(k+1)*x^k)/3^k;
}
cout << s << endl;
system("pause"); // или _getch();
return 0;
}
с отрицанием k
#include
using namespace std;
int main()
{
int a,k,s,x;
for (k=0; k<20; k++)
{
s +=((-1)*(k+1)*x^k)/3^k;
}
cout << s << endl;
system("pause"); // èëè _getch();
return 0;
}
и формулируйте вопрос корректнее.
в обоих решениях k=0 изначально
- 14.04.2017 00:50
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.