Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел ,кратных 3 и оканчивающихся на 2.Программа получает на вход количество чисел в последовательности,а затем сами числа.Количество чисел не превышает 1000.Введенные числа по модулю не превышают 30 000.Программа должна вывести одно число:количество чисел,кратных 3 и оканчивающихся на 2.
- 10.09.2018 02:43
- Информатика
- remove_red_eye 21147
- thumb_up 11
Ответы и объяснения 1
var
a,k,n,i:integer;
begin
k:=0;
writeln('Enter sequence size:');
readln(n);
for i:=1 to n do
begin;
readln(a);
if (a mod 3=0) and (a mod 10=2) then k:=k+1;
end;
writeln('Number of accepted:',k);
end.
- 11.09.2018 11:10
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.