Вопрос по информатике:
Помогите пожалуйста!!!
Найдите самый маленький натуральный делитель числа х, отличный от 1 (2<=х<=30000).
Входные данные
выходится натуральное число
выходные данные
выведите наименьший делитель числа х, отличный от 1
Примеры
входные данные
2
выходные данные
2
- 21.01.2017 14:04
- Информатика
- remove_red_eye 10422
- thumb_up 11
Ответы и объяснения 1
Var x:integer;
begin
readln(x);
for var i:=2 to x do
if (x mod i)=0 then begin
writeln('delitel: ',i);
exit;
end;
end.
- 22.01.2017 06:38
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.