Вопрос по информатике:
Помогите исправить ошибку в коде PASCAL. ПОЖАЛУЙСТА.
Заполнить файл f целыми числами, полученными с помощью генератора случайных чисел. Переписать их в файл g в обратном порядке.
var f:file of integer;
n,i,a,k,b:integer;
begin
randomize;
assign(f,'file1');
rewrite(f);
write('Сколько чисел ввести в файл n=');
readln(n);
for i:=1 to n do
begin
a:=random(50);
write(f,a);
end;
reset(f);
writeln('Исходный файл: ');
while not eof(f) do
begin
read(f,a);
write(a:4);
end;
writeln;
close(f);
reset(f);
for i:=0 to filesize(f) div 2 do{считаем до середины} //filesize - Возвращает текущий размер файла. ФУНКЦИЯ В ПАСКАЛЕ
begin
seek(f,i);{смотрим число в начале}
read(f,a);
seek(f,filesize(f)-i-1);{смотрим число в конце} // seek - Перемещает текущий указатель позиции файла на определенный компонент. ПРОЦЕДУРА В ПАСКАЛЕ
read(f,b);
seek(f,i); {с конца пишем в начало}
write(f,b);
seek(f,filesize(f)-i-1); {с начала пишем в конец}
write(f,a);
end;
close(f);
reset(f);
writeln('Преобразованный файл: ');
while not eof(f) do
begin
read(f,a);
write(a:4);
end;
writeln;
close(f);
end.
- 04.06.2017 15:55
- Информатика
- remove_red_eye 9144
- thumb_up 29
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.