Вопрос по информатике:
Паскаль: Написать программу для определения максимального элемента в одномерном массиве случайных вещественных чисел C[80]. Найти сумму всех элементов. Оформить ввод/вывод массива.
- 08.05.2018 01:25
- Информатика
- remove_red_eye 1869
- thumb_up 40
Ответы и объяснения 1
Var A:array [1..100] of real;
max:real; N,I:integer;
begin
N:=80;
for I:=1 to N do begin
a[I]:=random (20,5);
max:=a[1];
Sum:=Sum+a[I];
end;
for I:=1 to N do
if a[I] >max then max:=a[I];
for I:=1 to N do
write (A[I]:3);
writeln;
writeln (max);
writeln (sum);
end.
- 09.05.2018 12:43
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.