Вопрос по информатике:
Дан целочисленный массив из 20 элементов. Элементы массива могут быть
целыми числами от -1000 до 1000. Найдите минимальный элемент среди
положительных, делящихся на 3 и нечетных
- 11.12.2017 21:39
- Информатика
- remove_red_eye 10436
- thumb_up 31
Ответы и объяснения 1
Uses crt;
const n=20;
var i,min:integer;
a:array [1..n] of integer;
begin
randomize;
for i:=1 to n do
a[i]:= random(2001)-1000; {read (a[i])}{ручной ввод чисел}
min:=1001;
for i:=1 to n do
if (a[i]>0) and (a[i]mod 3=0) and (odd(a[i])) and (a[i]
if min1001 then
writeln(min)
else
writeln('нет чисел удовлетворяющих заданному условию');
end.
- 12.12.2017 06:50
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.