Вопрос по информатике:
У исполнителя Умножатор две команды, которым присвоены номера:
1. умножь на 3
2. прибавь 2
Первая из них увеличивает число на экране в 3 раза, вторая — прибавляет к числу 2. Составьте алгоритм получения из числа 2 числа 66, содержащий не более 5 команд. В ответе запишите только номера команд. В ответе запишите только номера команд. (Например, 12212 — это алгоритм: умножь на 3, прибавь 2, прибавь 2, умножь на 3, прибавь 2, который преобразует число 2 в 32.) Если таких алгоритмов более одного, то запишите любой из них.
- 24.01.2018 17:29
- Информатика
- remove_red_eye 1462
- thumb_up 10
Ответы и объяснения 2
Начнем с конца.
66 (делим на 3) [1]
22 ( на 3 не делится, значит отнимаем 2) [2]
20 ( на 3 не делится, значит отнимаем 2) [2]
18 (делим на 3) [1]
6 (делим на 3) [1]
2
Ответ : 11221
- 25.01.2018 21:24
- thumb_up 19
Ответ: 11221
Ход решения:
Procedure Find(a : Integer; s : String);
Begin
If a=66 then Writeln(s);
If Length(s)<5 then
Begin
Find(a*3,s+'1');
Find(a+2,s+'2');
end;
end;
Begin
Find(2,'');
end.
- 26.01.2018 17:07
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.