Вопрос по информатике:
Помогите пожалуйста, буду очень признателен. Код на C++:
Написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. Подсчитать количество слов в строке.
- 26.03.2018 07:58
- Информатика
- remove_red_eye 17127
- thumb_up 41
Ответы и объяснения 1
#include
#include
using namespace std;
int main(){
string str;
getline(cin,str); //вводим поток в строку
stringstream ss(str); //вводим строку в поток, при этом пробел делит слова на отдельные элементы
int i(0); //счётчик
while(ss>>str) //пока можно выводить элементы(слова)
i++;
cout << i;
cin.get();
cin.get();
return 0;
}
- 27.03.2018 14:44
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.