Вопрос по информатике:
Составить программу «Календарь XX столетия» , которая определяет день недели любого дня XX-го столетия. По введенному значению 1, 2, 3 вычисляет
1.номер дня недели по формуле, где D- день, М-месяц, G-год:
•S=[(12-M)/10]
•K=[(G-1900-S)*365,25]+[(M+12*S-2)*30,59]+D+29
•N=K-7[K/7] (N-вычисляется от 0-воскресенье до 6-суббота, []-целая часть)
2.день недели по его номеру
3.выход
- 16.05.2018 04:39
- Информатика
- remove_red_eye 16161
- thumb_up 33
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1128
begin
var D:=ReadInteger('Номер дня (1-31)');
var M:=ReadInteger('Номер месяца (1-12)');
var G:=ReadInteger('Номер года (1900-1999)');
var S:=(12-M) div 10;
var K:=Trunc(Int((G-1900-S)*365.25)+Int((M+12*S-2)*30.59)+D+29);
var N:=K mod 7;
case N of
0:Writeln('Воскресенье');
1:Writeln('Понедельник');
2:Writeln('Вторник');
3:Writeln('Среда');
4:Writeln('Четверг');
5:Writeln('Пятница');
6:Writeln('Суббота')
end
end.
- 17.05.2018 01:04
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.