Вопрос по информатике:
Составить программу и блок-схему для решения задачи. Решение каждой задачи сопроводить
пояснительной запиской с описанием используемых в задаче
конструкций языка Си.
A[N] Найти среднее геометрическое
элементов массива А . Ai > 0; N=10
- 12.07.2015 18:58
- Информатика
- remove_red_eye 11378
- thumb_up 37
Ответы и объяснения 1
#include
#include
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <
}
- 13.07.2015 09:21
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.