Вопрос по информатике:
Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например '0', '1', '2' или 'a', 'b', 'c') в которой нет двух смежных идентичных подпоследовательностей. Для n=11 последовательность может иметь вид "01020120210".
- 23.07.2018 13:57
- Информатика
- remove_red_eye 5092
- thumb_up 15
Ответы и объяснения 1
#include
#include
#include
using namespace std;
void main()
{
srand(time(NULL));
int n,k=0,k1=4;
cin >> n; //вводишь количество символов
string *s=new string [n];
for (int i = 0;i < n;++i)
{
while (k == k1)
{
k = rand() % 3;
}
switch (k)
{
case 0:s[i] = '0';cout << s[i];break;
case 1:s[i] ='1';cout << s[i];break; //вместо 0,1,2 пишешь свой алфавит .
case 2:s[i] ='2';cout << s[i];break;
}
k1 = k;
}
system("pause");
}
- 25.07.2018 00:40
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.