Вопрос по информатике:
Народ, выручайте. С информатикой очень туго.
Написать программу вычисляющую функцию S, значение которой равно единице, если в каждой строке матрицы есть нулевой элемент, и нулю в противном случае. Значение функции вычисляется для матриц А(3,4), В(3,3). Элементы матриц ввести с помощью подпрограммы процедуры
- 18.02.2018 22:13
- Информатика
- remove_red_eye 11065
- thumb_up 25
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1128
procedure MatInput(M:array[,] of integer);
begin
var nr:=Length(M,0);
var nc:=Length(M,1);
WritelnFormat('Введите построчно массив размером {0}x{1}',nr,nc);
for var i:=0 to nr-1 do
for var j:=0 to nc-1 do
Read(M[i,j]);
end;
function S(M:array[,] of integer):integer;
begin
Result:=0;
var Zero:integer;
for var i:=0 to Length(M,0)-1 do begin
Zero:=1;
for var j:=0 to Length(M,1)-1 do
if M[i,j]=0 then begin Zero:=0; Break end;
Result+=Zero;
if Result=1 then begin Result:=0; Exit end
end;
Result:=1
end;
begin
var A:=new integer[3,4]; MatInput(A);
var B:=new integer[3,3]; MatInput(B);
Writeln(S(A));
Writeln(S(B));
end.
Тестовое решение:
Введите построчно массив размером 3x4
1 2 3 4
5 6 7 8
9 0 1 2
Введите построчно массив размером 3x3
1 2 0
2 0 1
0 1 0
0
1
- 19.02.2018 08:26
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.