Вопрос по информатике:
Как на Pascal ABC написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры?
Количество цифр в числе неизвестно! Число целое. Очень желательно с объяснениями (вне программы). Заранее спасибо!!!
P.S. Я дам 15 баллов! Очень нужно!!!
- 22.10.2017 11:40
- Информатика
- remove_red_eye 11235
- thumb_up 33
Ответы и объяснения 1
Program LOL2016;
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.
если что то не понятно просто спроси и я обьясню :)
- 23.10.2017 06:36
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.