Вопрос по информатике:
Необходимо написать программу на Паскале, которая будет удалять из строки все стоящие подряд одинаковые элементы, если их больше 2. Примеры: aabbbc -> aac;
aabbbac -> c;
- 02.09.2018 01:45
- Информатика
- remove_red_eye 16573
- thumb_up 11
Ответы и объяснения 2
Var s:string; c:char; i:integer;
begin
write('s = '); readln(s);
i:=1;
while (i+2<=length(s)) do
if(s[i]=s[i+1])and(s[i+1]=s[i+2])
then begin
c:=s[i];
while (i<=length(s))and(c=s[i]) do delete(s,i,1);
i:=1;
end
else i:=i+1;
writeln(s);
end.
- 03.09.2018 07:47
- thumb_up 36
Рекурсивный подход.(Символы тоже удаляет)
function grad(s:string):string;
var
i:byte;
detect:boolean;
begin
while i < length(s) - 2 do
begin
inc(i);
if (s[i] = s[i+1]) and (s[i] = s[i+2]) then {проверка последовательности из 3 елементов}
begin
delete(s,i,3); {если да - удаляем их}
detect:=True; {логическая переменная регистрирует изменение строки}
end;end;
if detect = True then
s:=grad(s); {если строку изменили , проверяем не появились ли там еще последовальности}
grad:=s;
end;
var
s:string;
begin
readln(s);
writeln(grad(s));
end.
- 04.09.2018 18:25
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.