Вопрос по информатике:
Помогите пожалуйста,очень надо!!!!
.Составить программу.
Вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.Программа должна вывести"да" или "нет".
Заранее спасибо.
- 04.07.2018 13:01
- Информатика
- remove_red_eye 4883
- thumb_up 32
Ответы и объяснения 1
Uses crt;
var s:string;
i:integer;
l:boolean;
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin
if (mm-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')
else Writeln('Нет');
end.
- 05.07.2018 17:49
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.