Вопрос по информатике:
Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер.
- 19.09.2016 07:33
- Информатика
- remove_red_eye 5768
- thumb_up 28
Ответы и объяснения 1
Var
a:array[1..1000000]of integer;
i,min,n,c:integer;
begin
readln(n);
for i:=1 to n do
begin
read(a[i]);
if i = 1 then
min:=a[i];
if a[i]
min:=min+a[i] ;
a[i]:=min - a[i];
min:=min - a[i];
c:=i;
end;
end;
writeln('a[',c,']=',min);
end.
- 20.09.2016 11:34
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.