Вопрос по информатике:
Помогите написать программу на паскале :)
Составить программу, проверяющую, являются ли данные три числа взаимно простыми. Использовать подпрограмму.
- 17.02.2018 19:40
- Информатика
- remove_red_eye 10813
- thumb_up 36
Ответы и объяснения 1
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
a, b, c: integer;
{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
while b > 0 do
begin
t := b;
b := a mod b;
a := t;
end;
gcd := a;
end;
{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
isCoprime := gcd(gcd(a, b), c) = 1;
end;
begin
read(a, b, c);
if isCoprime(a, b, c) then write('Числа взаимно простые')
else write('Числа не являются взаимно простыми');
end.
- 18.02.2018 08:04
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.