Вопрос по информатике:
Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-9,9]. Найти количество ячеек, с нечетными номерами, которые содержат число --5. Напишите программу со всеми объяснениями пожалуйста!
- 15.09.2018 17:31
- Информатика
- remove_red_eye 10287
- thumb_up 33
Ответы и объяснения 1
var
a:array[1..20]of integer;
i,n,c:integer;
begin
for i:=1 to 20 do
begin
a[i]:=random(19)-9;
write(a[i],' ');
if i mod 2 =1 then
if a[i]=-5 then
c:=c+1;
end;
writeln;
writeln(c);
end.
- 16.09.2018 11:21
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.