Вопрос по информатике:
Помогите пожалуйста написать программу на Pascal.Это очень срочно!!!
Найдите и выведите на экран самую большую и самую маленькую цифру в трехзначном числе введенного с клавиатуры.
Очень желательно с объяснениями, т.к. в домашнем задании очень много однотипных задач. И просьба без "Введите число" и т.д.Заранее спасибо.
- 23.06.2018 15:32
- Информатика
- remove_red_eye 17158
- thumb_up 33
Ответы и объяснения 1
Var
N, a1, a2, a3, min, max: integer;
begin
readln(N);
N := abs(N);
a1 := N mod 10; //в а1 хранится разряд единиц введённого числа
N := N div 10; //"стираем" в N последнюю цифру
a2 := N mod 10; //в а2 хранится рязряд десятков числа N
N := N div 10;
a3 := N mod 10; //в а3 хранится рязряд сотен числа N
//-------------------------
//поиск минимума из цифр. в переменной мин
//хранится наименьшее число на данном шаге.
min := a1;
if a2 < min then
min := a2;
if a3 < min then
min := a3;
//---------------------------
//поиск максимума
max := a1;
if a2 > max then
max := a2;
if a3 > max then
max := a3;
//--------------------------
writeln('min - ', min, ' max - ', max);
end.
- 24.06.2018 10:48
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.