Вопрос по информатике:
Составьте программу, которая заполняет массив b [1..15] случайными целыми числами в диапазоне от 1 до 20 и выводит все тройки элементов, упорядоченные
строго по возрастанию. (Pascal ABC).
- 23.07.2018 02:41
- Информатика
- remove_red_eye 2647
- thumb_up 49
Ответы и объяснения 1
Program CrazyCoder;
var ar:array[1..15] of integer;
i:integer;
begin;
var i1:=1;
writeln('Тройки элемента масива');
while i1<=15 do
begin
var ar1:=ArrRandomInteger(4,1,20);
sort(ar1);
ar[i1]:=ar1[1];
ar[i1+1]:=ar1[2];
ar[i1+2]:=ar1[3];
writeln(ar1[1]:4,ar1[2]:4,ar1[3]:4);
i1:=i1+3;
end;
writeln('Масив:');
for i:=1 to 15 do
write(ar[i]:4);
end.
- 24.07.2018 15:27
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.