Вопрос по информатике:
Составьте программу, которая заполняет массив a[1..20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое элементов с четными значениями и нечетными индексами
- 14.07.2018 21:16
- Информатика
- remove_red_eye 16684
- thumb_up 27
Ответы и объяснения 2
Составьте программу" которая заполняет массив а[1..20] случайными целыми числами в диапазоне от 1 до 30 и выводит наэкран элементы , значения которых являются четными и кратными3.Program Task;
Var a: Array [1..20] of Integer;
i: Integer;
Begin
For i := 1 To 20 Do
Begin
a[i] := Random(30) + 1;
If a[i] Mod 3 = 0 Then
Write(a[i], ' ');
End;
ReadLn;
End.
- 15.07.2018 13:31
- thumb_up 27
Program CrazyCoder;
var
a:array[1..20] of integer;
i,n,c:integer;
begin
for i:=1 to 20 do
begin
a[i]:=random(10)+1;
write(a[i],' ');
if i mod 2 = 1 then
if a[i] mod 2 = 0 then
begin
c:=c+a[i];
n:=n+i;
end;
end;
writeln;
writeln('Среднее арифметическое: ', c/n);
end.
- 16.07.2018 17:37
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.