Вопрос по информатике:
Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 2 и выводи на экран количество элементов, равных 1
- 15.03.2018 10:48
- Информатика
- remove_red_eye 17233
- thumb_up 5
Ответы и объяснения 2
Var ar:array[1..10] of integer;
i,k:integer;
begin;
randomize;
writeln('Array:');
for i:=1 to 10 do
begin;
ar[i]:=random(3);
write(ar[i]:4);
if ar[i]=1 then inc(k);
end;
writeln;
writeln(k);
end.
- 16.03.2018 09:42
- thumb_up 4
Var a: array[1..10] of integer;
var i, n: integer;
begin
randomize;
for I:=1 to 10 do
begin
a[I]:= random(3);
if a[I] = 1 then inc(n);
end;
write(n);
end.
- 17.03.2018 10:15
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.