Вопрос по информатике:
В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)
- 08.02.2018 09:43
- Информатика
- remove_red_eye 3298
- thumb_up 15
Ответы и объяснения 1
Var a, b, c, x1, x2, D:real;
begin
writeln ('Введите значение a, b и c');
readln (a, b, c);
D:=sqr(b)-4*a*c;
if D>0 then
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
writeln ('x1 = ', x1, ' x2 = ', x2)end
else
writeln ('Корней нет');
end.
- 09.02.2018 12:34
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.