Вопрос по информатике:
Составить программу на языке Паскаль, для решения задач:
1".Зная цену компьютера b рублей,определить хватит ли покупателю на a рублей купить компьютер?"
2."Зная длину забора d метров,определить хватит ли сетки а метров.чтобы обнести этот забор"?
- 03.01.2015 00:24
- Информатика
- remove_red_eye 4209
- thumb_up 34
Ответы и объяснения 1
1)
var
a,b,e:real;
begin
write('Сколько стоит компьютер - ');
readln(b);
write('Сколько денег у покупателя - ');
readln(a);
e:=a-b;
if e>0 then
writeln('Покупателю хватит денег на покупку компьютера ценой - ',b,'руб.')
else
begin
e:=e*(-1);
write('Покупатель не сможет купить компьютер ценой - ',b,'руб. Ему не хватает - ',e,'руб.');
end;
end.
2)
var
a,b,e:real;
begin
write('Длина забора (м) - ');
readln(b);
write('Длина сетки (м) - ');
readln(a);
e:=a-b;
if e>0 then writeln('Сетки хватит чтобы обнести забор.')
else
begin
e:=e*(-1);
write('Сетки не хватит чтобы обнести забор.');
end;
end.
- 03.01.2015 05:13
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.