Вопрос по информатике:
Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.
- 11.05.2018 21:43
- Информатика
- remove_red_eye 17804
- thumb_up 11
Ответы и объяснения 1
Var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
begin
if a[i]='1' then b:=b+st;
st:=2*st;
end;
writeln(b);
end.
- 12.05.2018 06:27
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.