Вопрос по информатике:
Помогите составить программу в Pascal!
Задана последовательность слов. Определить частоту вхождения каждого из слов в последовательность.
- 19.11.2016 13:19
- Информатика
- remove_red_eye 16565
- thumb_up 8
Ответы и объяснения 1
Var s,r,k: string;
j: integer;
begin
write('строка: '); readln(s);
foreach k in s.Split(' ').Distinct do
begin
j:=0;
foreach r in s.Split(' ') do
if r=k then j:=j+1;
writeln('слово ','"',k,'"',' встречается ',j,' раз');
end;
end.
- 20.11.2016 14:40
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.