Вопрос по информатике:
Составьте программу проверки эквивалентности двух логических функций. Постройте соответствующие таблицы истинности(программно).
1.Проверьте что X → Y эквивалентна not (x) or y
- 02.11.2015 03:03
- Информатика
- remove_red_eye 8536
- thumb_up 33
Ответы и объяснения 1
//так и не осознала как вводить функции с клавиатуры. Спрошу у учителя.
var b1,b2,b:boolean;
function imp(a, b : boolean) : boolean;
begin
imp:=(not a) or b;
end;
begin;
writeln('Implication');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,imp(b1,b2):7);
writeln('not (x) or y');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,((not b1) or b2):7);
For b1:=false to true do
For b2:=false to true do
if imp(b1,b2)((not b1) or b2) then
begin;
writeln('Не эквивалентны');
exit;
end;
writeln('Эквивалентны');
end.
- 03.11.2015 13:29
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.