Вопрос по информатике:
Для настольной игры используются карточки с номерами от 1 до N. Одна карточка потерялась. Найдите ее, зная номера оставшихся карточек.
Входные данные
Дано число N, далее N-1 номер оставшихся карточек (различные числа от 1 до N).
Выходные данные
Программа должна вывести номер потерянной карточки.
- 27.10.2017 05:30
- Информатика
- remove_red_eye 12731
- thumb_up 33
Ответы и объяснения 1
Var n,i,k,s1,s2:integer;
begin
write('n='); readln(n);
s1:=n; s2:=0;
for i:=1 to n-1 do
begin
write('k',i,'='); readln(k);
s1:=s1+i; s2:=s2+k;
end;
writeln('Потерялась карточка ',s1-s2);
end.
Пример:
n=5
k1=1
k2=3
k3=4
k4=5
Потерялась карточка 2
- 29.10.2017 00:42
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.