Вопрос по информатике:
Помогите срочно ребят!!!!!! Требуется написать программу для перевода целых чисел из восьмеричной системы счисления в десятичную.
- 03.08.2016 10:43
- Информатика
- remove_red_eye 12704
- thumb_up 29
Ответы и объяснения 1
Var o,d,k,l: integer;
begin
read(o);
d := 0;
k := 1;
l := 1;
while l <= o do
begin
d := d + k*(o div l mod 10);
l := l * 10;
k := k * 8
end;
writeln(d)
end.
- 05.08.2016 00:01
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.