Вопрос по информатике:
Составьте программу которая заполняет массив s [1..15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами
- 26.09.2016 08:27
- Информатика
- remove_red_eye 7667
- thumb_up 34
Ответы и объяснения 1
Если в паскале то вот
vara:array [1..30] of integer;i,s,k,n:integer;h:real;begins:=0;k:=0;writeln('введите количество чисел');read(n);randomize;for i:=1 to n do begina[i]:=random(100);write(a[i]:3);end;writeln();for i:=1 to n do beginif (a[i] mod 2=0) and (i mod 2=0) then begins:=s+a[i];k:=k+1;end;end;if k>1 then h:=s/k;writeln(h); if k=0 then begin writeln('таких чисел нет'); read; halt; end;end.
- 27.09.2016 12:02
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.