Вопрос по информатике:
3. Напишите программу, которая подсчитывает, сколько чисел из последовательности делятся на 3 и при этом заканчиваются на 4. На выход программа получает сначала количество чисел в последовательности, а затем сами числа по одному. Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
Входные данные/Выходные данные
8/4
12/
14/
24/
54/
44/
33/
84/
114/
- 10.05.2015 11:21
- Информатика
- remove_red_eye 5323
- thumb_up 37
Ответы и объяснения 1
Var
a:array[1..1000]of integer;
i,n,k,c,q:integer;
begin
readln(n);
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10 = 4) then
begin
k:=a[i];
c:=0;
while k>0 do
begin
c:=c + k mod 10;
k:= k div 10;
end;
if c mod 3 = 0 then
q:=q+1;
end;
end;
writeln(q);
end.
- 11.05.2015 22:29
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.