Вопрос по информатике:
Найти стоимость заданного количества ткани. Цена и количество вводятся с клавиатуры. ( Составьте программу Паскаль)
Язык программы Паскаль.
- 19.08.2018 01:23
- Информатика
- remove_red_eye 12101
- thumb_up 13
Ответы и объяснения 1
Var
a,b,c: integer;
x,y,z:string;
begin
x:='рубль';
y:='рубля';
z:='рублей';
writeln('Сколько стоит метр ткани?(в рублях)');
readln(a); writeln('Сколько вы хотите купить ткани?(в метрах квадратных)'); readln(b);
c:=a*b;
if c=1 then
begin
writeln('Это будет стоить',' ',c,' ',x);
end;
if (2<=c) and (c<=4) then
begin
writeln('Это будет стоить',' ',c,' ',y);
end;
if (5 <= c) and(c <= 1000000) then
begin
writeln('Это будет стоить',' ',c,' ',z);
end;
end.
В зависимости от результата программа будет выводить разное окончание.
1 рубль;
3 рубля;
100 рублей.
- 21.08.2018 00:31
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.