Вопрос по информатике:
Помогите, пожалуйста, написать программу в Паскаль, с помощью функции.
дан вектор n (1<=n<=100).Найти минимальный элемент, который не превышает целое число m.
- 23.01.2016 22:27
- Информатика
- remove_red_eye 6091
- thumb_up 32
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1088
const
nn=100;
type
Vector=array[1..nn] of integer;
function Min(a:Vector; n:integer):integer;
var
i,m:integer;
begin
m:=a[1];
for i:=2 to n do
if a[i]
end;
var
V:Vector;
i,n,m,mn:integer;
begin
Write('Количество элементов вектора: '); Read(n);
Write('Значение m: '); Read(m);
Randomize;
Writeln('*** Сгенерированный вектор ***');
for i:=1 to n do begin
V[i]:=Random(101)-50;
Write(V[i],' ')
end;
Writeln;
mn:=Min(V,n);
if mn<=m then Writeln('Минимум ',mn,' не превышает ',m)
else Writeln('Минимум ',mn,' превышает ',m)
end.
Тестовое решение:
Количество элементов вектора: 20
Значение m: -42
*** Сгенерированный вектор ***
-12 10 -47 8 6 -22 -4 8 -50 -2 36 -38 -39 -41 11 -46 41 -22 -50 24
Минимум -50 не превышает -42
- 24.01.2016 06:57
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.