Вопрос по информатике:
Написать программу. Ввести последовательность чисел размерностью n. В этой последовательности:
найти минимальный и максимальный элементы.
среднее арифметическое отрицательных чисел
Вывести на экран значения min и max элементов и их номера, и среднее арифметическое
- 25.05.2015 07:05
- Информатика
- remove_red_eye 7351
- thumb_up 40
Ответы и объяснения 1
// PascalABC.NET 3.0, сборка 1088
var
n,i,max,min,s,t,k:integer;
begin
Write('Введите количество членов последовательности: ');
Read(n);
Writeln('Вводите числа через пробел');
max:=-32768; min:=32767; s:=0; k:=0;
for i:=1 to n do begin
Read(t);
if t
if t>max then max:=t;
if t<0 then begin s:=s+t; Inc(k) end
end;
Writeln('Min=',min,', max=',max,', ср.арифм.=',s/k:0:5)
end.
Тестовое решение:
Введите количество членов последовательности: 7
Вводите числа через пробел
25 -6 39 -118 271 24 -15
Min=-118, max=271, ср.арифм.=-46.33333
- 27.05.2015 00:28
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.