Вопрос по информатике:
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.
Входные данные
Входная строка содержит три целых числа, разделённых пробелами.
Выходные данные
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.
Примеры
входные данные
1 2 1
выходные данные
2
- 21.08.2017 00:17
- Информатика
- remove_red_eye 16086
- thumb_up 36
Ответы и объяснения 1
Var
a,b,c,d:longint;
begin
read(a,b,c);
If a=b then inc(d);
If a=c then inc(d);
If b=c then inc(d);
if d=1 then d:=2;
writeln(d);
end.
- 21.08.2017 03:43
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.