Вопрос по информатике:
Напишите программу на паскале
Дано трехзначное число. Определить кратна ли сумма его цифр числу а.
Пример работы программы:
Входные данные Выходные данные
633 No
4
540 Yes
2
- 11.09.2017 04:41
- Информатика
- remove_red_eye 12236
- thumb_up 20
Ответы и объяснения 1
Var
a,b,c,d,e:longint;
begin
readln(a);
readln(c);
d:=d+a mod 10;
d:=d+a div 10 mod 10;
d:=d+a div 100 mod 10;
if d mod c = 0 then writeln('Yes') else writeln('No');
end.
- 12.09.2017 07:56
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.