Вопрос по информатике:
Помогите пожалуйста решить!
Даны две точки в плоской прямоугольной системе координат. Напишите программу, определяющую, которая из точек находится ближе к началу координат. Запишите решение с помощью оператора boolean.
- 03.06.2018 12:17
- Информатика
- remove_red_eye 1653
- thumb_up 39
Ответы и объяснения 1
Var x1,y1,x2,y2:integer;
p1,p2:real;
b:boolean;
begin;
readln(x1);
readln(y1);
readln(x2);
readln(y2);
p1:=sqrt(sqr(x1)+sqr(y1));
p2:=sqrt(sqr(x2)+sqr(y2));
if p1>p2 then b:=true else b:=false;
writeln(b);
end.
- 04.06.2018 14:55
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.