Вопрос по информатике:
Всем привет.
Вообщем, вот задача и к ней необходимо написать программу(Pascal). Код программы будет ниже.Нужно проверить его на ошибки и дать коментарии к коду. Если код неправильный прошу подкорректировать. Буду очень признателен. Заранее спасибо.
Задача:
Дана последовательность из n действительных чисел (n <= 100). Написать программу для подсчета суммы этих чисел.
Код программы:
var massiv: array [1..100] of real;
sum: real;
n,i: integer;
begin
clrscr;
writeln ('Введите количество чисел');
readln (n);
for i:=1 to n do
begin
writeln ('Введите ',i,'-ое число');
readln (massiv [i]);
end;
sum:=0;
for i:=1 to n do
sum:= sum + massiv [i];
writeln ('Сумма последовательности равна ', sum:0:4);
readln;
end.
- 01.05.2017 09:51
- Информатика
- remove_red_eye 10246
- thumb_up 21
Ответы и объяснения 1
Var i,n:integer;
k,k1:real;
begin;
readln(n);
for i:=1 to n do //повторить n раз
begin; //начало тела цикла
readln(k1); //читаем промежуточную переменную
k:=k+k1; //прибавляем к общей сумме
end; //конец тела цикла
writeln('Result:',k); //вывод общей суммы
end.
- 02.05.2017 23:20
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.