Вопрос по информатике:
.Дано число к (0<к<366) числу к=1 соответствует день 1 января . среда .Напишите программу которая опред. День который соотв.введеному числу к.
Ребята,умоляю очень срочно помогите решить.
Пожалуйста пожалуйста пожалуйста
очень прошу
даю 30 баллов
умоляю помогите
- 06.12.2015 09:33
- Информатика
- remove_red_eye 8665
- thumb_up 26
Ответы и объяснения 2
Var
k: integer;
begin
writeln('Введите число');
readln(k);
case(k mod 7) of
1: writeln('Среда');
2: writeln('Четверг');
3: writeln('Пятница');
4: writeln('Суббота');
5: writeln('Воскресенье');
6: writeln('Понедельник');
0: writeln('Вторник');
end;
end.
- 07.12.2015 14:16
- thumb_up 8
#include
using namespace std;
int main (){
setlocale(LC_ALL,"Rus");
int dp,N,S=7;
cout<<"\n День=";
cin>>N;
while(N>S){ N=N-7;
}
dp=N;
switch(dp)
{
case 1:
cout<<"\n Среда"<
case 2:
cout<<"\n Четверг"<
case 3:
cout<<"\n Пятница"<
case 4:
cout<<"\n Суббота"<
case 5:
cout<<"\n Воскресенье"<
case 6:
cout<<"\n Понедельник"<
case 7:
cout<<"\n Вторник"<
}
system("pause");
return 0;
}
- 08.12.2015 21:00
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.