Вопрос по информатике:
Помогите написать программу на Си. Дана строка. Преобразовать в ней все строчные буквы (как латинские, так и русские) в прописные, а прописные — в строчные.
- 18.06.2017 00:47
- Информатика
- remove_red_eye 1817
- thumb_up 16
Ответы и объяснения 1
#include
#include
using namespace std;
int main(){
//---------------------
char S[256];
cin >> S;
int i,n;
n=strlen(S);
for(i=0;i<=n;i++){
if (isupper(S[i])==true){
S[i]=tolower(S[i]);
}else{
S[i]=toupper(S[i]);
}
}
cout << S;
//---------------------
return 0;
}
- 18.06.2017 06:08
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.