Вопрос по информатике:
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от 0 до 1000.Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1.
Паскаль АБС
- 27.09.2018 23:14
- Информатика
- remove_red_eye 6556
- thumb_up 29
Ответы и объяснения 1
// PascalABC.Net 3.0, сборка 1088
const
n=30;
var
a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
Writeln('*** Исходный массив ***');
k:=0;
for i:=1 to n do begin
a[i]:=Random(1001);
Write(a[i],' ');
if (a[i] mod 3 = 0) and (a[i] mod 10 = 1) then Inc(k)
end;
Writeln;
Writeln('Количество найденных элементов равно ',k)
end.
Тестовое решение:
*** Исходный массив ***
503 187 764 452 351 819 339 940 681 369 938 874 639 212 633 825 983 830 121 801 889 36 479 14 357 382 631 8 402 61
Количество найденных элементов равно 3
- 28.09.2018 06:40
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.