Вопрос по информатике:
Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива.
var i,n:integer;
g: real;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
write ('введите ',i,'элемент');
read(a[i]);
end;
n:=0;
for i:=1 to 10 do
n:=n+a[i];
write (n);
g:=n/10;
write (g);
end.
- 05.08.2016 17:15
- Информатика
- remove_red_eye 14123
- thumb_up 11
Ответы и объяснения 1
У Вас всё считает правильно, но рекомендую Вам изучить вопрос: "В чем отличие между Write и Writeln?"
При выводе добавьте "ln"
- 06.08.2016 12:25
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.