Вопрос по информатике:
Сколько существует различных символьных последовательностей длины 6 в четырехбуквенном алфавите A, B, C, D которые содержат НЕ МЕНЕЕ ДВУХ буквы A
- 12.09.2017 11:30
- Информатика
- remove_red_eye 11644
- thumb_up 31
Ответы и объяснения 1
Ответ: 1909
Var
s : String;
n : Integer;
Function IncS(a : String) : String;
Begin
a[Length(a)]:=Chr(Ord(a[Length(a)])+1);
If a[Length(a)]>'D' then
IncS:=IncS(Copy(a,1,Length(a)-1))+'A'
else IncS:=a;
end;
Function Check(a : String) : Boolean;
Begin
Check:=False;
If (Pos('A',a)>0) then
Begin
Delete(a,Pos('A',a),1);
If (Pos('A',a)>0) then Check:=True;
end;
end;
Begin
s:='AAAAAA'; n:=0;
While s'DDDDDD' do
Begin
{ Writeln(s); }
If Check(s) then Inc(n);
s:=IncS(s);
end;
Writeln(n);
end.
- 13.09.2017 07:37
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.