Вопрос по информатике:
Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
- 21.10.2017 06:40
- Информатика
- remove_red_eye 19889
- thumb_up 8
Ответы и объяснения 1
Var pos,neg,i: integer;
begin
pos:=0; neg:=0;
i:=1;
while i0 do
begin
readln(i);
if i>0 then pos:=pos+1
else neg:=neg+1;
end;
writeln('число положительных чисел = ',pos);
writeln('число отрицательных чисел = ',neg);
end.
- 22.10.2017 02:30
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.