Вопрос по информатике:
Составьте программу для решения задачи: даны две точки, заданные своими
координатами. Определить , какая из них находится ближе к началу координат.
- 21.01.2016 08:50
- Информатика
- remove_red_eye 7848
- thumb_up 19
Ответы и объяснения 1
Расстояние от точки до начала координат находится как длина гипотенузы прямоугольного треугольника, катетами которого являются координаты точки. Поскольку нам нужны не сами расстояния, а лишь сравнить их, то можно сравнивать квадраты, чтобы не извлекать корня.
// PascalABC.NET 3.0, сборка 1088
var
x1,x2,y1,y2,r1,r2:real;
begin
Write('Введите координаты первой точки: '); Read(x1,y1);
Write('Введите координаты второй точки: '); Read(x2,y2);
r1:=sqr(x1)+sqr(y1); r2:=sqr(x2)+sqr(y2);
if r1>r2 then Writeln('Ближе вторая точка')
else
if r1
end.
Тестовое решение:
Введите координаты первой точки: 16.3 -11.7
Введите координаты второй точки: 15.8 12
Ближе вторая точка
- 22.01.2016 03:15
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.